<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://deque.blog/xmlrpc.php">
<title>The alias method, or transforming data to increase efficiency (Clojure). &#8211; Deque</title>
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=deque.blog&amp;id=121223011&amp;t=1498427531&amp;back=https%3A%2F%2Fdeque.blog%2F2017%2F06%2F25%2Falias-method-and-data-transformation%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//dequeweb.wordpress.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Deque &raquo; Feed" href="https://deque.blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="Deque &raquo; Comments Feed" href="https://deque.blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Deque &raquo; The alias method, or transforming data to increase efficiency&nbsp;(Clojure). Comments Feed" href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1496863874h&ver=4.8-RC2-40878"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyFj90OwiAMhV9IbKbTuAvjszCsjo1CY1kW314Y0cSfzBvSlvP1nMLEygQf0UegUbEbr9YLTGwCKSHr8P7RrY3ICn5jzg4o0GNkbQY1d0tyE26Y5sQ6ZgXh2Wp0SEm2hBHvn1Quu+S1aFPity3fUESll+xIKnbJ6E88ylHKHZCE75OCWvAh2kTLq/jaWayAxxbYaY/zrkv6VHpCCYSZONGxqnfNpq6a7aF/AIiomJ0=' type='text/css' media='all' />
<link rel='stylesheet' id='plane-fonts-css'  href='https://fonts.googleapis.com/css?family=Raleway%3A400%2C500%2C700%2C900%7CNoto+Serif%3A400%2C700%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext&#038;ver=4.8-RC2-40878' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJx9jdEKAiEQRX8oG6wgfIi+xbXJDHWGnRHZv8/oZaPYt3PhHC50NoGqYlXQBxYU4DYBZ18RRJeM+yCygy0t1fBRTedA5ScozXBuMVWBnm4RVUCJDZMM+v+xSiKSyRS8Jqpfw9yzT/NWOuOUKQ6MMKzVfEfXcrEnZ93xcLbu+QKkfGJK' type='text/css' media='all' />
<style id='plane-style-inline-css' type='text/css'>
.site-header { background-image: url(https://dequeweb.files.wordpress.com/2017/01/green.jpg); }
</style>
<link rel='stylesheet' id='print-css-3-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-4-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=' type='text/css' media='all' />
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFztEKwjAMBdAfsquTiXsRv6XWOFKXtDbphn69HeiDMBQCgdzDJXZOBtmP5QJiQ517gfx4rybIxv4ChnDITqEh5A/2kRVYF0vxjCOYIpDdUG+16BpXXIqiBCIVraTfLyFPCPNfFkCT8zeTQfC5tJ7o2Hb9Yde3+24bXjRNW9I='></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dequeweb.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='10 things Idris improved over&nbsp;Haskell' href='https://deque.blog/2017/06/14/10-things-idris-improved-over-haskell/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/" />
<link rel='shortlink' href='http://wp.me/p8cDDR-62q' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fdeque.blog%2F2017%2F06%2F25%2Falias-method-and-data-transformation%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fdeque.blog%2F2017%2F06%2F25%2Falias-method-and-data-transformation%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="The alias method, or transforming data to increase efficiency (Clojure)." />
<meta property="og:url" content="https://deque.blog/2017/06/25/alias-method-and-data-transformation/" />
<meta property="og:description" content="This post is dedicated to describing a wonderful and beautiful small algorithm that is not widely known. It allows to pick a random element among an enumerated distribution of elements, where each …" />
<meta property="article:published_time" content="2017-06-25T18:20:42+00:00" />
<meta property="article:modified_time" content="2017-06-25T18:20:42+00:00" />
<meta property="og:site_name" content="Deque" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@qduval" />
<meta name="twitter:text:title" content="The alias method, or transforming data to increase efficiency&nbsp;(Clojure)." />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@qduval" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s0.wp.com/i/webclip.png" />
<link rel="search" type="application/opensearchdescription+xml" href="https://deque.blog/osd.xml" title="Deque" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="Deque" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Functions In - Fictions Out" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://deque.blog/feed/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="The alias method, or transforming data to increase efficiency&nbsp;(Clojure). | Deque on WordPress.com" />
<meta name="description" content="This post is dedicated to describing a wonderful and beautiful small algorithm that is not widely known. It allows to pick a random element among an enumerated distribution of elements, where each element is associated a weight. This need is frequently encountered, for instance in property based testing libraries. In test.check, it correspond to the&hellip;" />
<link rel="amphtml" href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<style type="text/css" id="custom-colors-css">.site-main .post-navigation a:hover{background-color:transparent !important}@media only screen and (min-width:767px){.nav-menu ul ul a{color:#333}}@media only screen and (max-width:767px){.nav-menu ul ul li:hover>a,.nav-menu ul ul li.current_page_item>a,.nav-menu ul ul li.current-menu-item>a,.nav-menu ul ul li.current-menu-ancestor>a,.nav-menu ul ul li.current_page_ancestor>a,.nav-menu ul ul li.current-post-parent>a{opacity:1}}.site-footer,.footer-widget-area .widget-title,.site-footer a:hover{color:#fff}.nav-menu>ul>li>a{color:#fff}.site-title a,.site-title a:hover{color:#4f4f4f}.site-main .post-navigation a:hover,.site-main .post-navigation a:focus{background:#f7f7f7}blockquote p{color:#828a8c}blockquote cite{color:#384750}.site-description{color:#43515a}.site-top,.site-footer,.search-expand{background-color:#6b6b6b}h1,h2,h3,h4,h5,h6,.entry-title a{color:#6b6b6b}.entry-meta a:hover,.entry-meta a:focus,.page-links a{color:#6b6b6b}.site-main .comment-navigation a,.site-main .paging-navigation a,.site-main .post-navigation a,.site-main .post-navigation .meta-nav{color:#6b6b6b}.widget-title a{color:#686868}a,.site-main .post-navigation a,.entry-meta,.comment-meta{color:#60742e}.widget_flickr #flickr_badge_uber_wrapper td a:last-child{color:#5d712d}button,input[type="button"],input[type="reset"],input[type="submit"],#infinite-handle span{background-color:#6d6d6d}.more-link a:hover,.more-link a:focus,.page-links a:hover,.page-links a:focus{background-color:#6d6d6d}.site-main .comment-navigation a:hover,.site-main .comment-navigation a:focus,.site-main .paging-navigation a:hover,.site-main .paging-navigation a:focus,.site-main .post-navigation a:hover,.site-main .post-navigation a:focus{background-color:#6d6d6d}a:hover,a:active,.menu ul ul li>a:hover,.nav-menu ul ul li:hover>a,.nav-menu ul ul li.focus a,.nav-menu ul ul li.current_page_item>a,.nav-menu ul ul li.current-menu-item>a,.nav-menu ul ul li.current-menu-ancestor>a,.nav-menu ul ul li.current_page_ancestor>a,.nav-menu ul ul li.current-post-parent>a,.entry-title a:hover,.entry-title a:focus{color:#6d6d6d}.site-main .post-navigation a:hover,.site-main .post-navigation a:focus{color:#686868}.widget_flickr #flickr_badge_uber_wrapper td a:last-child:hover{color:#686868}.site-header{background-color:#c3d19d}.site-footer a{color:#f7f9f5}.footer-widget-area .widget_flickr #flickr_badge_uber_wrapper td a:last-child{color:#f7f9f5}</style>
</head>

<body class="post-template-default single single-post postid-23214 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<div class="site-top">
		<div class="content-wrapper">
			<nav id="site-navigation" class="main-navigation" role="navigation">
				<button class="menu-toggle" aria-controls="menu" aria-expanded="false"><span class="screen-reader-text">Primary Menu</span></button>
				<div class="nav-menu"><ul id="menu-primary" class="menu"><li id="menu-item-8" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8"><a href="/">Home</a></li>
<li id="menu-item-16112" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16112"><a href="https://deque.blog/series/">Series</a></li>
<li id="menu-item-17453" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17453"><a href="https://deque.blog/games/">Games</a></li>
<li id="menu-item-9" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9"><a href="https://deque.blog/about/">About</a></li>
</ul></div>			</nav><!-- #site-navigation -->

			<div class="site-search">
				<button class="search-toggle"><span class="screen-reader-text">Search</span></button>
				<div class="search-expand">
					<div class="search-expand-inner">
						<form role="search" method="get" class="search-form" action="https://deque.blog/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>					</div>
				</div>
			</div><!-- .site-search -->
    	</div>
	</div><!-- .site-top -->

	<header class="site-header" role="banner">
			<div class="site-branding">
								<h1 class="site-title"><a href="https://deque.blog/" rel="home">Deque</a></h1>
				<h2 class="site-description">Functions In &#8211; Fictions Out</h2>
			</div><!-- .site-branding -->
	</header><!-- .site-header -->

	<div id="content" class="site-content">
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-23214" class="post-23214 post type-post status-publish format-standard hentry category-clojure">
	<header class="entry-header">

		<h2 class="entry-title"><a href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/" rel="bookmark">The alias method, or transforming data to increase efficiency&nbsp;(Clojure).</a></h2>
					<div class="entry-meta">
				<span class="posted-on"><a href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/" rel="bookmark"><time class="entry-date published" datetime="2017-06-25T18:20:42+00:00">June 25, 2017</time></a></span><span class="byline"><span class="author vcard"><a class="url fn n" href="https://deque.blog/author/qduval/">DeQue</a></span></span>			</div><!-- .entry-meta -->
		
	</header><!-- .entry-header -->

	
		<div class="entry-content">
			<p>This post is dedicated to describing a wonderful and beautiful small algorithm that is not widely known. It allows to pick a random element among an enumerated distribution of elements, where each element is associated a weight.</p>
<p>This need is frequently encountered, for instance in property based testing libraries. In <a href="https://github.com/clojure/test.check">test.check</a>, it correspond to the library function <a href="https://github.com/clojure/test.check/blob/495acdd42aca1e966e029d809c23c0606225b2c4/src/main/clojure/clojure/test/check/generators.cljc#L342-L345">frequency</a> which allows to select a random generator based on frequency of occurence (the weight).</p>
<p>We will first describe two classic methods to solve this problem before jumping to the Alias Method, a very efficient algorithm. We will describe how it works and give one possible implementation.</p>
<p>We will end this post by taking some distance and discuss the importance of data transformations to build efficient algorithms, and one reason that might explain why tend to fail to see these transformation so often in our everyday code.</p>
<p> </p>
<h3>Stating the problem</h3>
<hr />
<p>As input, we have a bunch of elements <b>xs</b> and each element is associated a <b>weight</b>. This weight is proportional to the probability of picking that element among <b>xs</b>. We call this kind of distribution an <b>enumerated distribution</b>.</p>
<p>Our algorithm should output a random generator such that:</p>
<ul>
<li>Each time we call it, it outputs an element from our elements <b>xs</b></li>
<li>The probability of taking <b>x</b> from <b>xs</b> is P(x) = Weight(x) / TotalWeight</li>
<li>The TotalWeight is the sum of Weight(x) for all <b>x</b> of the elements <b>xs</b></li>
</ul>
<p>We will name the function that implements this algorithm (and returns the desired generator) <b>enumerated-distribution-gen</b>.</p>
<p> </p>
<h3>Usage example</h3>
<hr />
<p>Let us take as input a map associating to the keyword <b>:a</b> the weight 1, to <b>:b</b> the weight 2 and to <b>:c</b> the weight 1. We expect our <b>enumerated-distribution-gen</b> function to output a random generator that will:</p>
<ul>
<li>Output <b>:a</b> 25% of the time</li>
<li>Output <b>:b</b> 50% of the time</li>
<li>Output <b>:c</b> 25% of the time</li>
</ul>
<p>Here is how it would translate in term of Clojure code:</p>
<script src="https://gist.github.com/1f0123b2a057cd72046db24d22a5dfb7.js"></script>
<p>We will now go through different implementation of this algorithm.</p>
<p> </p>
<h3>Linear naive algorithm</h3>
<hr />
<p>The most naive algorithm consist in computing the sum of the weights, which we will name <i>total-weight</i> and to randomly pick a number between 0 and this <i>total-weight</i> (excluded). We then linearly scan the collection to find the appropriate match.</p>
<p>For instance, if we pick as input {:a 1, :b 2, :c 1}, we compute its <i>total-weight</i>, yielding 4. Each random generation will randomly generate an double <b>d</b> between 0 and 4, and scan the collection to find the correct match:</p>
<ul>
<li>If <b>d</b> is in [0, 1), we output <b>:a</b></li>
<li>If <b>d</b> is in [1, 3), we output <b>:b</b></li>
<li>If <b>d</b> is in [3, 4), we output <b>:c</b></li>
</ul>
<p> </p>
<h6>Implementation</h6>
<p>Finding the correct match is rather simple: we subtract to <b>d</b> the weight of each element. The first element that makes <b>d</b> strictly negative is the one we select.</p>
<script src="https://gist.github.com/27098bbdf07201751fa95d94f5483ade.js"></script>
<p>This function makes use of the <b>sum-weights</b> helper function that sums the weight of our input elements:</p>
<script src="https://gist.github.com/559a2888d25680e2fb072fac86ed1e03.js"></script>
<p>We can run our function a few time to see how it behaves:</p>
<script src="https://gist.github.com/99ce216508d659406d4370575ce6eaf2.js"></script>
<p> </p>
<h6>Alternate implementations</h6>
<p>Equivalently, we can precompute the cumulative sum of the weights, and select the first cumulative weight that is higher than the number <b>d</b> we generate. In terms of algorithm complexity, these implementations are equivalent to the one provided above:</p>
<ul>
<li>O(N) pre-processing time (summing the weights)</li>
<li>O(N) processing time at each rand (scanning)</li>
</ul>
<p>Two implementations (from Rich Hickey and Stuart Halloway) of this variant of the naive algorithm are shown in this <a href="https://stackoverflow.com/questions/14464011/idiomatic-clojure-for-picking-between-random-weighted-choices">stack overflow thread</a>.</p>
<p> </p>
<h3>Binary search</h3>
<hr />
<p>The implementation based on cumulative weights gives us some insight on how we can improve our algorithm. Since cumulative weights form an increasing sequence of weights, the weights are sorted and so we can binary search into it.</p>
<p>Based, on binary search, we can improve our algorithm complexity to:</p>
<ul>
<li>O(N) pre-processing time (summing the weights)</li>
<li>O(log N) processing time at each rand (binary search)</li>
</ul>
<p>In case the random generator output by <b>enumarated-distribution-gen</b> is used a lot of times, this can yield some interesting performance boost. We will not delve further into this. The implementation is very similar to the previous one, and is left as an exercise for the reader.</p>
<p> </p>
<h3>Alias method</h3>
<hr />
<p>We will now cover the alias method, an algorithm that allows to randomly pick an element from an enumerated distribution in O(1), given a typical O(N log N) pre-processing time.</p>
<p>In this section, we will describe the algorithm, starting with an analogy with buckets of water, before moving to the implementation in the next section.</p>
<p> </p>
<h6>Let&#8217;s talk about buckets</h6>
<p>Let us imagine a bucket of water of volume <b>Vtotal</b>, where <i>Vtotal</i> is the sum of the weights of the elements in the enumerated distribution. We fill this bucket such that each element <b>x</b> is associated with the volume <b>Weight(x)</b>.</p>
<p>This bucket equivalent to our enumerated distribution. Our <b>{:a 1, :b 2, :c 1}</b> initial example can be viewed as as bucket of 4 litres capacity, filled with:</p>
<ul>
<li>1 litre of <b>:a</b></li>
<li>2 litres of <b>:b</b></li>
<li>1 litre of <b>:c</b></li>
</ul>
<p>In this view, picking one random element in our enumerated distribution is equivalent to randomly picking (with a uniform distribution) one random atom in the bucket.</p>
<p> </p>
<h6>Splitting in several buckets</h6>
<p>Things start to be interesting when we split our single bucket of 4 litres into 2 buckets of 2 litres each, and fill them intelligently:</p>
<ul>
<li>We can fill the first bucket with our 2 litres of <b>:c</b></li>
<li>We can fill the second bucket with 1 litre of <b>:a</b> and 1 litre of <b>:c</b></li>
</ul>
<p>To randomly pick an element, we first randomly pick one bucket. The selected bucket is a new enumerated distribution, smaller than the initial one.</p>
<p> </p>
<h6>A good split</h6>
<p>It is important to note that we should divide our initial bucket of volume <b>total-weight</b> into buckets of equal volumes. This makes the random selection of one of the <b>K</b> bucket a simple uniform integer roll between <b>0</b> and <b>K-1</b>. Had we not do that, we would end up with an additional enumerated distribution to select our bucket.</p>
<p>The trick is then to choose our number of bucket <b>K</b> and the way we fill each of these buckets in such a way that each of the sub-problems are made so simple than they can be decided by a simple random roll. The Alias method is such a way.</p>
<p> </p>
<h6>The Alias Method</h6>
<p>The Alias Method gives us a way to split our probability volume into buckets, such that these buckets are filled with at most 2 elements of our initial enumerated distribution. This makes it possible to randomly pick an element in two random rolls:</p>
<ul>
<li>One integer roll, to pick the bucket</li>
<li>One double roll, to pick an element from the bucket</li>
</ul>
<p>We select our number of bucket <b>K</b> as being equal to the number of <b>xs</b> elements, denoted <b>N</b>, minus one. Each bucket has a volume <b>Vbucket</b> equal to <b>Vtotal</b> divided by <b>N &#8211; 1</b>.</p>
<p>We fill each bucket by picking an element with a weight <b>W</b> inferior to its volume <b>Vbucket</b>. This leaves <b>Vremaining</b> (<b>Vbucket</b> &#8211; <b>W</b>) as remaining volume to fill. We fill it with an element whose weight is higher than <b>Vremaining</b> (it exists by construction).</p>
<p>This process will completely drain one element at each iteration, and consume some of the volume of another element as well. We repeat this process until all the buckets are filled, at which point each of our elements are drained (by construction).</p>
<p> </p>
<h6>Example</h6>
<p>Let us consider the following example: <b>{:a 1, :b 4/3, :c 1, :d 2/3}</b>:</p>
<ul>
<li>The total volume <b>Vtotal</b> equal to 4</li>
<li>The number of bucket <b>K</b> equal to 3 (4 elements &#8211; 1)</li>
<li>Each bucket has a volume <b>Vbucket</b> equal to <b>4/3</b></li>
</ul>
<p>We start with all buckets empty:</p>
<pre>
Elements = {:a 1, :b 4/3, :c 1, :d 2/3}
Bucket 1 = Empty
Bucket 2 = Empty
Bucket 3 = Empty
</pre>
<p><u>Step 1</u>: We fill the first bucket with <b>:a</b> whose volume 1 is inferior to <b>Vbucket</b> (4/3). There is still 1/3 litres to fill in this bucket. We take them from element <b>:b</b>:</p>
<pre>
Elements = {:b 1, :c 1, :d 2/3}
Bucket 1 = {:a 1, :b 1/3}
Bucket 2 = Empty
Bucket 3 = Empty
</pre>
<p><u>Step 2</u>: We fill the second bucket with <b>:c</b> whose volume 1 is inferior to <b>Vbucket</b> (4/3). We complete the remaining 1/3 litres by taking them from our element <b>:b</b> again:</p>
<pre>
Elements = {:b 2/3, :d 2/3}
Bucket 1 = {:a 1, :b 1/3}
Bucket 2 = {:c 1, :b 1/3}
Bucket 3 = Empty
</pre>
<p><u>Step 3</u>: We fill the third bucket, whose volume is 4/3, with the remaining 2/3 litres of <b>:b</b> and <b>:d</b>. This completes our distribution in buckets:</p>
<pre>
Elements = Empty
Bucket 1 = {:a 1, :b 1/3}
Bucket 2 = {:c 1, :b 1/3}
Bucket 3 = {:b 2/3, :d 2/3}
</pre>
<p>We are now done. To randomly select an element, we pick a random bucket uniformly and then roll a double between 0 and 1. If the roll is higher than the ratio of the first element in the bucket, we pick the second element, else the first element.</p>
<p>For instance, we pick {:c 1, :b 1/3} by first rolling 1. Then we pick <b>:b</b> by rolling 0.9 which is higher than the ratio of <b>:c</b> in the bucket (3/4).</p>
<p> </p>
<h3>Implementing the Alias Method</h3>
<hr />
<p>Now that we know how the Alias Method works, we will implement it. Since the Alias Method stays voluntarily vague on the order in which we can pick our elements to fill the buckets, there are several possible implementations available for us.</p>
<p> </p>
<h6>Chosen implementation</h6>
<p>We will use the nice semantics of <b>sorted-set</b> to help us. We will store each element and its associated weight as a key in a sorted set of pairs <b>[weight value]</b>. So the weight will act as primary attribute in the ordering: the elements will be sorted by increase weights.</p>
<p>As a consequence, by construction, the first element of the sorted set will have a weight inferior to the volume of a bucket, and the last element will have a weight superior to the remaining volume of the bucket.</p>
<p>At each iteration, we will therefore pick the first element of the set, drain it completely to fill the bucket as much as possible. We will then pick the last element of the set and drain enough of it to fill the remaining of the volume.</p>
<p> </p>
<h6>High level Clojure code</h6>
<p>The algorithm translates into the following Clojure code, in which we first check if the input collection has enough element:</p>
<script src="https://gist.github.com/77048bae2305957fcd6db981ffaf13e8.js"></script>
<ul>
<li>If we have just a collection of one element to pick from, we short circuit and return a function that constantly returns the same number</li>
<li>Otherwise, we construct our vector of buckets with <b>enum-dist-&gt;buckets</b>, and implement our algorithm based on two uniform random rolls</li>
</ul>
<p> </p>
<h6>Clojure Code to create buckets</h6>
<p>The construction of the buckets is based on the <b>sorted-set</b> collection of Clojure, and always picks the first and last element of the container to fill the current bucket:</p>
<script src="https://gist.github.com/e624f5fb6f0aa83c24dfca0432356220.js"></script>
<p>Where <b>fill-one-bucket</b> is the function that implements the draining of the quantities <i>to-verse</i> into a bucket. It is the core of the algorithm:</p>
<script src="https://gist.github.com/a218cb10363b4fff003164f4a43e0297.js"></script>
<p>We can test our <b>fill-one-bucket</b> function in the REPL and see how it implements one iteration of the Alias Method:</p>
<script src="https://gist.github.com/d9552b2478c05c18fd9746629a8f058c.js"></script>
<p>We can also test the <b>enum-dist-&gt;buckets</b> and check that it transforms our enumerated distribution into buckets correctly:</p>
<script src="https://gist.github.com/d4e0afe3d90fc61ea59b81807f6322c5.js"></script>
<p> </p>
<h3>Conclusion: data transformation vs code tuning</h3>
<hr />
<p>In this post, we saw how to generate random number from an enumerated distribution containing N element, in constant time, given a pre-processing time of O(N log N).</p>
<p> </p>
<h6>Simple yet effective data transformations</h6>
<p>Aside from the algorithm itself, the fascinating bit about the Alias Method is how simple it ends up being: it is about transforming pairs of value and probabilities, into tuples of two elements and a probability.</p>
<p>It shows that <b>switching between data representation can unlock unsuspected performance improvements</b>, and also show that it does not systematically require complex data structure to speed up an algorithm tremendously.</p>
<p> </p>
<h6>Failing to see these transformations</h6>
<p>The Alias Method is pretty smart: it is not something we would naturally come up with. But it asks the question of <b>how many data transformation we miss</b>, that would improve our run-time efficiency tremendously, instead of focusing so much of our efforts on code tuning.</p>
<p>In my years doing professional development, I have seen plenty of simple yet missed opportunities of data transformation which would have improved the efficiency of the code by much. We do miss a lot of trivial ones, and it is not because they are hard.</p>
<p><b>We often simply do not look for them</b>. Lots of what we learned in OOP books makes us think in terms of fixed entities, with one chosen representation, and very few incentives to actually copy data to transform it into another form (mapping it).</p>
<p>While having several ways to represent the same data will certainly comes at a cost if introduced gratuitously, this might be the key to unlock better performance in our software as well, and not stay stuck in tuning a sub-optimal algorithms.</p>
<p> </p>
<h6>Escaping the trap in our minds</h6>
<p>Clojure (and Functional Programming in general) avoids us falling into the trap of the &#8220;one representation to rule them all&#8221; by making us love data transformation.</p>
<p>As shown in this post, we can leverage this love for data transformations to build smarter data structure for more efficient algorithm. And I will certainly work on doing it more often in the years to come.</p>
<hr />
<a href="https://twitter.com/quduval" class="twitter-follow-button" data-show-count="false" data-text-color="#333A42" data-link-color="#426f86">Follow @quduval</a>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-23214" class="share-twitter sd-button share-icon no-text" href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-23214" class="share-facebook sd-button share-icon no-text" href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/?share=facebook" target="_blank" title="Share on Facebook"><span></span><span class="sharing-screen-reader-text">Share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-23214" class="share-google-plus-1 sd-button share-icon no-text" href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-121223011-23214-5950308bd2f86' data-src='//widgets.wp.com/likes/#blog_id=121223011&amp;post_id=23214&amp;origin=dequeweb.wordpress.com&amp;obj_id=121223011-23214-5950308bd2f86' data-name='like-post-frame-121223011-23214-5950308bd2f86'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>					</div><!-- .entry-content -->

	
	<footer class="entry-meta entry-footer">
		<span class="cat-links"><a href="https://deque.blog/category/clojure/" rel="category tag">Clojure</a></span>	</footer><!-- .entry-footer -->
</article><!-- #post-23214 -->
				<nav id="nav-below" class="post-navigation clear" role="navigation">
	
		<div class="nav-previous"><a href="https://deque.blog/2017/06/14/10-things-idris-improved-over-haskell/" rel="prev"><span class="meta-nav">Previous Article</span> 10 things Idris improved over&nbsp;Haskell</a></div>		
	
	</nav><!-- #nav-below -->
	
			
		
		</main><!-- #main -->
	</div><!-- #primary -->

	<div id="secondary" class="widget-area" role="complementary">
				<aside id="recent-posts-3" class="widget widget_recent_entries">		<h3 class="widget-title">Recent Posts</h3>		<ul>
					<li>
				<a href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/">The alias method, or transforming data to increase efficiency&nbsp;(Clojure).</a>
						</li>
					<li>
				<a href="https://deque.blog/2017/06/14/10-things-idris-improved-over-haskell/">10 things Idris improved over&nbsp;Haskell</a>
						</li>
					<li>
				<a href="https://deque.blog/2017/06/05/lisp-meta-programming-for-c-developers-automatic-traces-part-2/">Lisp Meta-Programming for C++ Developers: Automatic traces (Part&nbsp;2)</a>
						</li>
					<li>
				<a href="https://deque.blog/2017/06/01/clojure-high-performance-fibonacci/">Clojure High Performance&nbsp;Fibonacci</a>
						</li>
					<li>
				<a href="https://deque.blog/2017/05/26/lisp-meta-programming-for-c-developers-automatic-traces/">Lisp Meta-Programming for C++ Developers: Automatic&nbsp;Traces</a>
						</li>
				</ul>
		</aside>		<aside id="archives-5" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<ul>
			<li><a href='https://deque.blog/2017/06/'>June 2017</a></li>
	<li><a href='https://deque.blog/2017/05/'>May 2017</a></li>
	<li><a href='https://deque.blog/2017/04/'>April 2017</a></li>
	<li><a href='https://deque.blog/2017/03/'>March 2017</a></li>
	<li><a href='https://deque.blog/2017/02/'>February 2017</a></li>
	<li><a href='https://deque.blog/2017/01/'>January 2017</a></li>
	<li><a href='https://deque.blog/2016/12/'>December 2016</a></li>
	<li><a href='https://deque.blog/2016/11/'>November 2016</a></li>
		</ul>
		</aside><aside id="top-posts-3" class="widget widget_top-posts"><h3 class="widget-title">Popular</h3><ul>				<li>
										<a href="https://deque.blog/2017/06/14/10-things-idris-improved-over-haskell/" class="bump-view" data-bump-view="tp">
						10 things Idris improved over Haskell					</a>
									</li>
							<li>
										<a href="https://deque.blog/2017/05/09/lisp-meta-programming-for-c-developers-first-macros/" class="bump-view" data-bump-view="tp">
						LISP Meta-Programming for C++ Developers: First Macros					</a>
									</li>
							<li>
										<a href="https://deque.blog/series/" class="bump-view" data-bump-view="tp">
						Series					</a>
									</li>
							<li>
										<a href="https://deque.blog/2017/06/01/clojure-high-performance-fibonacci/" class="bump-view" data-bump-view="tp">
						Clojure High Performance Fibonacci					</a>
									</li>
							<li>
										<a href="https://deque.blog/2017/06/25/alias-method-and-data-transformation/" class="bump-view" data-bump-view="tp">
						The alias method, or transforming data to increase efficiency (Clojure).					</a>
									</li>
							<li>
										<a href="https://deque.blog/games/" class="bump-view" data-bump-view="tp">
						Games					</a>
									</li>
							<li>
										<a href="https://deque.blog/2017/05/02/lisp-meta-programming-for-c-developers-introduction/" class="bump-view" data-bump-view="tp">
						LISP Meta-Programming for C++ Developers: Introduction					</a>
									</li>
							<li>
										<a href="https://deque.blog/2017/05/20/a-clojure-spec-for-generic-binary-trees/" class="bump-view" data-bump-view="tp">
						A Clojure.Spec for Generic Binary Trees					</a>
									</li>
			</ul></aside>	</div><!-- .widget-area -->

		</div>

	<footer class="site-footer" role="contentinfo">
		<div class="content-wrapper">

			

			<div class="site-credit">
				<a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a>
				
							</div><!-- .site-credit -->

		</div>
	</footer><!-- .site-footer -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201725y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=20111117'></script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/deque.blog\/2017\/06\/25\/alias-method-and-data-transformation\/":23214};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
		<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"121223011","siteName":"Deque","siteURL":"https:\/\/deque.blog","icon":"<img alt='' src='https:\/\/s1.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/plane","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/dequeweb.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdeque.blog%2F2017%2F06%2F25%2Falias-method-and-data-transformation%2F","themeURL":"https:\/\/wordpress.com\/theme\/plane\/","xhrURL":"https:\/\/deque.blog\/wp-admin\/admin-ajax.php","nonce":"e2afc79946","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"dfb6c595b3\" \/>","referer":"https:\/\/deque.blog\/2017\/06\/25\/alias-method-and-data-transformation\/","canFollow":"1","statusMessage":"","customizeLink":"https:\/\/dequeweb.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fdequeweb.wordpress.com%2F2017%2F06%2F25%2Falias-method-and-data-transformation%2F","postID":"23214","shortlink":"http:\/\/wp.me\/p8cDDR-62q","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/deque.blog\/23214","statsLink":"https:\/\/wordpress.com\/stats\/post\/23214\/deque.blog","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Plane","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in the Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/dequeweb.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdeque.blog%2F2017%2F06%2F25%2Falias-method-and-data-transformation%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyVjs0OgkAMhF/ItWCMxoPxWQpUKO521/0BH99FI1EPRE+dTOebDIxO1VYiSYQ+QEMD1+Ru6z6s4O1lknI6tSwBNF8owDVRog6l0eQXwrU1JlvqCfUTXUEY2dE/0IfxDcaOTI65VIHTKDQBggO3GNnKL+mHWNiDjWFRFXowGCL5rJQdyHtuctXsLTXU05apYVYLaWdDVGeN7CF06Fna183QyRzL7WFTFLtys+/vggOnCQ=='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		<script>
			var _comscore = _comscore || [];
			_comscore.push({
				c1: "2",
				c2: "7518284"
			});
			(function() {
				var s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];
				s.defer = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<p class="robots-nocontent"><img src="https://sb.scorecardresearch.com/p?c1=2&c2=7518284&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" alt="" style="display:none;" width="1" height="1" /></p>
		</noscript><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'121223011','blog_tz':'0','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'121223011','v':'wpcom','tz':'0','user_id':'0','post':'23214','subd':'dequeweb'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGNrd29+Smw0TDhnZmRTK0hlRi9QSGh6bi9GXVhBJWIlZlR5U1JMLU8/MkNtblkvY1dRRmNMMywwa2x1JVdNRDdKcDJDVTRHNWM1fm9LdHFuLTUvUEdhSFJyQy1Ubl94aTN3OVlGemFRLUwlMjhTS21pSUN1R2dRQnxINVp8JTJfYkFBakZJQ1k5NzdBd2d1d2FjTEYuM1I0ODdBWDl2cE5QJVRbWGJqa3NRfjI9fGJFcFY/WFtCWzh0Lj9UU1ptMXUuOFRRcSwvL2tMOF1fUFF+VmZWUitTa1c9bVQ0NEtCUm10TGs/VERbcWxabi43Wno5cXxuZThYRj9NeV85'}]);
_stq.push([ 'clickTrackerInit', '121223011', '23214' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>